Tuesday, August 07, 2007

Mio c310x - SEC S3C2410X Test B/D driver not found

The problems during firmware update manifest them selves in a variety of ways. 1. Blue screen of death 2. Computer restarts 3. Update application complains that the SEC S3C2410X driver is unavailable. I have 3 computers and I had all 3 of the above problems. Once I got the updated driver - everything worked - smooth as silk! The update has 2 steps. 1. Update the firmware and 2. Update the maps. I was having problems with step 1. Everytime I would start the update firmware app, MIO device would be restarted in a special mode and at that point it would require a driver called "SEC S3C2410X Test B/D". Without this the firmware would not uptake to the device. The Mio was being started in a special mode so as to update the firmware and thus needed a special driver for this boot loader mode. This driver is available in the following file: http://www.klubin.hrleon.com/pda/ROM_do_p550_rg.zip (25mb) or you can download just the driver files from http://www.gpspassion.com/upload/SECdriver.zip Here are the steps: 1. Download the file - duh! 2. Unzip it 3. "secbulk.inf file" is the file used to install the driver. If you used ROM_do_p550_rg.zip, then within the folder "USBDownloaderFirware" you will find the secbulk.inf file. If you used SECdriver.zip - then the inf file is right in there. 5. Make sure that you have the USB drivers installed for your MIO. (The USB drivers are in the Update DVD - install\usbdriver - just right click on the WCEUSBSH.inf file and select Install) 6. Plugin your MIO. 7. Start the update firmware app. (Either through the auto start program or its the iboot.exe file in the folder install\iboot). 8. Click the update button. 9. Your Mio device should shut down and restart automatically. When it comes back up it should have something like "processing upgrade...." on its screen. Your computer will complain that you dont have the drivers for "SEC S3C2410X Test B/D". 10. If you get the screen that allows you to point to the driver file then point it at the "secbulk.inf" file that you downloaded. (its in the USBDownloaderFirware folder if you used the Rom_do.... download). If you dont get the screen - then right click on My Computer and select "Properties". Goto the device manager. You should see a device with an error mark called "SEC S3C2410X Test B/D". You should be able to right click on it and select "Update". Again point it to the SecBulk.inf file in the USBDownLoaderFirware folder. 11. Now disconnect your MIO and perform a hard reset (turn on and off the button at the bottom). 12. Re-connect. 13. Cross your fingers and toes. 14. Run the update app iboot.exe (Install\iboot folder of the upgrade DVD). It should bring you back to the following screen 15. Hit Update. (Remember - once the firmware has been updated - all your old maps will not work. Though in most cases all your old settings - like custom POIs should all work. Also if you have customized your data.zip file - back it up - as it will be overwritten). (The screen while the device is in the special boot loader mode - that allows for the firmware to be updated). 16. Hopefully - the firmware will upload to your device. Once the firmware has been updated - all your old maps are useless and you will have to update the maps to the new ones provided on the DVD. Those instructions are in another post : http://therajahs.blogspot.com/2007/08/updating-maps-on-mio-c310x-with-2007.html

19 comments:

Anonymous said...

Many thanks for putting this blog posting online. I was just updating my C310X and I ran into the exact "SEC S3C2410X Test B/D" driver not found issue. Thanks to your links to the drivers I was able to update my firmware and am now in the process of updating my maps.

You rock!

Maria said...

my comp keeps on rebooting!! i hate this!! what can it be?? thanks email me at chamosservices@aol.com thank you!

Drumman said...

Awesome!! Thanks for the help!! This saved me from hours of frustration...much appreciated!!

Anonymous said...

Wow!!! My MIO is back again!!!! Thank you dude!!!

Anonymous said...

Worked very easily. First USB port I tried didn't work so good, but tried another usp port and voila! That missing SEC driver really pissed me off yesterday and I'm glad I found this page after hours of searching. Now why doesn't MIO have a link to this page or make that missing driver download available to people like me right from their site? Not a sign of a good company. I just hope this update they put out addresses the many problems with the older mapping loaded. I use my gps everyday for work to find over 7 houses a day or more in different towns in my State and I could tell you 5 different roads that were in the purple section, where mio didn't like routing me on. Some of these roads were main roads, not little back roads.

Anonymous said...

OMG! We must always give thanks to those that come before us. Without them how would we ever survive...

Bless the author of this blog! Bless you my son, go and be prosperous... haa haa

Anonymous said...

You are my hero! Thanks a bunch!!!

Jags said...

This really works... saved my day.... thank you so much for posting the instructions online... you rock!!!

Anonymous said...

Thank you for posting this.

Anonymous said...

Ditto to the thanks expressed above. I am an operating systems programmer & even *I* found this whole mess distastefully difficult and problematic.
You clearly have great patience & skill to put up with the headaches of this platform.
Thanks again!
/* Why can't MIO themselves have the sense to collect such useful information in a self-help database? */

Anonymous said...

I was so happy to get my update CD (Circuit City's were all sold out except on line) and then got stuck with this error. Great Job! You saved the day!

Will said...

Thanks so much!
First answer in Google. You saved me much frustration.

Will

KatieCake said...

I am soooo frustrated.

I have tried all of the steps above. I even tried this on an X as well as a Vista PC. I am stuck at installing?changing the driver when it stalls in the update firmware screen. I am getting an error message that there is no software for the driver (the one on the download).

ARRRGGGH!!

Someone please help me....

Anonymous said...

Excellent info mate... Thanx a lot

Anonymous said...

You are a lifesaver. Please, please continue the good work!

AndrĂ¡s said...

same problem, but have worked on
C250 too. Thanks, awesome.

Csaszi said...

Yes, I do!
I have C250, working too. Thanks!

Anonymous said...

saved my day thanx a lot..worked just fine on Mio C220..

AMDIRUL ROZAIMI (AMD) said...

PAGE NOT FOUND!!
????